vendorrisk.com down
Incident Report for VendorRisk
Resolved
Connectivity was restored around 12:05 PM EST. Our hosting company is still investigating the root cause.
Posted May 04, 2016 - 12:17 EDT
Investigating
The VendorRisk application is not currently accessible as of 11:38 AM. It appears to be an issue upstream, so we are waiting on confirmation from our hosting provider.
Posted May 04, 2016 - 11:45 EDT