Downtime
Incident Report for VendorRisk
Resolved
The app should be back up and our hosting company is monitoring the situation.
Posted Nov 04, 2016 - 11:05 EDT
Investigating
The VendorRisk app is currently inaccessible. It appears to be a network connectivity issue and our hosting company is looking into it.
Posted Nov 04, 2016 - 10:43 EDT